Page 2 of 2 FirstFirst 12
Results 11 to 16 of 16

Thread: Soundstream Picasso Nano Review & Pics

  1. #11
    Controller AL9000's Avatar
    Join Date
    Aug 2010
    Location
    Jupiter
    Posts
    389
    Real Name
    Alan
    Damn! Sorry to hear that, J. Keep us updated.


  2. #12
    Junior Member
    Join Date
    Jul 2012
    Location
    NM
    Posts
    25
    Real Name
    Javan
    Yeah, its a little depressing. On a lighter note, played with the EQ some today.

    Deck EQ (only form of processing ATM), fronts & rears are HP filtered at 63hz.


    & an FFT reading from my iPhone of white noise with some serious smoothing. lol


    & a 20~20khz sine sweep at the same volume with zero smoothing.


    That was about as good as I could get it with such a limited EQ, but it sounds pretty damn good to me.

  3. #13
    Junior Member
    Join Date
    Jul 2012
    Location
    NM
    Posts
    25
    Real Name
    Javan
    Well, got an email back & they were happy to exchange the amp if it was defective.
    I pulled it & for shits & giggle dropped it on the "test bench" just to make sure, and wouldn't ya know the damn thing worked just fine. So I threw it back in the car (power & ground only) and it went back into protection when I powered the remote terminal. Tried some new fuses (even though these tested okay) and I guess that's all it took. I changed all of the fuses so I'm not quite sure which was the culprit, so I threw them all away. I haven't canceled the return authorization yet just in case, but it seems to be back in action. Fingers crossed bad fuse was the only issue.

  4. #14
    Junior Member
    Join Date
    Jul 2012
    Location
    NM
    Posts
    25
    Real Name
    Javan
    Another quick update, both amps have been performing flawlessly without any more hassles.
    Great sounding amps, and I will be picking up another 4ch sometime soon.

  5. #15
    Controller AL9000's Avatar
    Join Date
    Aug 2010
    Location
    Jupiter
    Posts
    389
    Real Name
    Alan
    I'm glad everything worked out.


  6. #16
    Junior Member
    Join Date
    Jun 2011
    Posts
    2
    I'm using the Picasso Nano amps as well. I have a 1.650 driving my substage, a 4.520 bridged to my midbass and a 2.350 for my tweets. So far I like them, I would say they are rated about right but definitely not "powerhouse" amps. Of course for $120, you can get 110x4....so buy multiples!

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •