Results 1 to 10 of 10

Thread: Forum Slow, Laggy, and eats all my memory.

  1. #1
    Founding Member
    Join Date
    Aug 2010
    Posts
    496

    Forum Slow, Laggy, and eats all my memory.

    Takes 50% CPU to run, too.

    The only reason I don't post here more is because it's difficult to do so. Pages take a long time to load. The auto-save lags the reply window so I can type 1-2 sentences and nothing shows up on the screen, just to pop in all at once after I pause and wait for it to show up. In the task manager screen, my browser is taking over twice the memory used compared to my second most memory intensive activity (leaving an email inbox window open) which is maybe 30-50% more ram intensive than general browsing. If I have more than 3 or 4 forum windows open CPU cycles goes up like crazy.

    In extreme cases the browser instance will freeze till the one page that is opening finishes.

    This is not a problem with other websites (OK that's not true, Home Depot, Lowes, and MidwayUSA, and Cabelas sites all do the same thing, but noone else.), just this one. Seems like there must be a way to deliver the content more efficiently.

  2. #2
    Devil's Advocate Adam_MSS's Avatar
    Join Date
    Aug 2010
    Posts
    1,578
    Real Name
    Adam
    What browser?
    You don't use science to show that you're right, you use science to become right. - R.Munroe

    The important thing in science is not so much to obtain new facts as to discover new ways of thinking about them. - W.L.Bragg



  3. #3
    Founding Member
    Join Date
    Aug 2010
    Posts
    496
    Internet Explorer. Please do not tell me to switch browsers. It gets old.

  4. #4
    Big Daddy Chad's Avatar
    Join Date
    Aug 2010
    Location
    East-Central Illinois
    Posts
    1,570
    I'll try it on IE tonight.. I'm not noticing it.

  5. #5
    MSS Supporting Vendor SyracuseCustoms's Avatar
    Join Date
    Dec 2011
    Location
    Syracuse, NY
    Posts
    92
    I am running Firefox.... Works great ! Not saying change but its an option :thumbsup:
    ***** AUTHORIZED DEALER FOR *****
    ARC AUDIO - ADDICTIVE AUDIO - TRU TECHNOLOGY - BRAX - HELIX - DYNAUDIO - GERMAN MAESTRO - PHOENIX GOLD - JVC - STINGER
    ** TERRITORY RESTRICTIONS APPLY **
    :Jackhammer:CUSTOM FABRICATION: WOOD, STEEL, ALUMINUM,FIBERGLASS & PLEXI :Jackhammer:

  6. #6
    Indecisive Tuner BowDown's Avatar
    Join Date
    Oct 2010
    Location
    Central, NY
    Posts
    749
    Quote Originally Posted by SyracuseCustoms View Post
    I am running Firefox.... Works great ! Not saying change but its an option :thumbsup:
    Same here.

    Supporting Vendor? Sweet man!
    2010 Fusion Sport: SQ Install w/Dash Sub - Build Log of the Month Winner | July 2011


    Nexus 7 | DAC | miniDSP | Aura MR2150 x 3 | NRT18-8 | RS180-4 | neo8-s

  7. #7
    Devil's Advocate Adam_MSS's Avatar
    Join Date
    Aug 2010
    Posts
    1,578
    Real Name
    Adam
    Quote Originally Posted by Whiterabbit View Post
    Internet Explorer. Please do not tell me to switch browsers. It gets old.
    Well I was really just looking to isolate the issue. In your personal forum settings you should be able to select the reply editor that's in use. Perhaps switching to the most basic version.

    I've really tried to minimize the burden this site places on browsers. The new reply editor with the auto save feature does run a script frequently so it may be causing your issues.

    IE does get the short end of the stick as I do all my site testing in Chrome, Firefox and Opera (in that order of preference). VB has tried to implement some workarounds for IE but I think they'd admit that their software is not optimized for IE. With the new server the forum has seemed pretty fast in chrome lately.

    I'll peruse the VB support area and see if they have any more recent IE fixes.
    You don't use science to show that you're right, you use science to become right. - R.Munroe

    The important thing in science is not so much to obtain new facts as to discover new ways of thinking about them. - W.L.Bragg



  8. #8
    Controller AL9000's Avatar
    Join Date
    Aug 2010
    Location
    Jupiter
    Posts
    389
    Real Name
    Alan
    I ran several speed tests with IE, IE64, Firefox, Safari for Windows, and Opera. They all came back with the same average speed.

    Website size: 95.49 KB
    Load time: 0.48 to 0.51 seconds

    Have you tried opening the site straight from the IP address to see if it may be some kind of DNS resolving error?


  9. #9
    Devil's Advocate Adam_MSS's Avatar
    Join Date
    Aug 2010
    Posts
    1,578
    Real Name
    Adam
    I went through the various pages using the Page Speed extension for chrome and identified some opportunities for compression and utilization of better browser caching, but those would only speed up initial load times. I'll work on those items. The one amazon link toward the bottom of the page does take almost 600 milliseconds to pull a remote image, but I've got it set up to be the last thing to load and it's only on the forum main page.

    I'm not able to identify anything that would cause the memory and CPU cycle issues. Those are ultimately issues related to how the browser handles the content. It's the whole reason there are browser speed wars. It's a battle to see who can handle the content most efficiently while providing users with a good web experience. Chrome is my choice because it's fast, intuitive, and no-frills (unless you add them).
    You don't use science to show that you're right, you use science to become right. - R.Munroe

    The important thing in science is not so much to obtain new facts as to discover new ways of thinking about them. - W.L.Bragg



  10. #10
    Member Salami's Avatar
    Join Date
    Oct 2010
    Location
    Charlotte
    Posts
    66
    I have no issues using FireFox. Loads fairly fast. Loads pretty fast on my phone too while I am taking a d%&p.

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •